Issue #14189 has been updated by shevegen (Robert A. Heiler).


Good catch. 

I guess the japanese hackers all happily use ruby 2.5.x already. :)

2.4.3 was recently released. Guess it is a stable variant on the
2.4.x branch.

Webrick at https://rubygems.org/gems/webrick has the ">= 2.5.0dev"
tag, and presently 2.5.0dev is not available. If there are no 
breaking changes, perhaps the 2.4.x branch works fine and webrick
could default to 2.4.x. for the time being - that should solve 
the issue for now.

By the way, perhaps webrick should be added to "bundled_gems" too
like many other distributed gems:

    https://github.com/ruby/ruby/blob/trunk/gems/bundled_gems


----------------------------------------
Bug #14189: Webrick 1.4.0. release requires unreleased ruby version 2.5.0dev
https://bugs.ruby-lang.org/issues/14189#change-68449

* Author: tb / panorama9.com (Thomas Balslv)
* Status: Open
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: 
* Backport: 2.3: UNKNOWN, 2.4: UNKNOWN
----------------------------------------
Hi Team!

We have just encountered a blocking bug in the Webrick gem version 1.4.0.
The gemspec is requiring an as yet unreleased version of ruby:

Gem::InstallError: webrick requires Ruby version >= 2.5.0dev.
An error occurred while installing webrick (1.4.0), and Bundler cannot continue.
Make sure that `gem install webrick -v '1.4.0'` succeeds before bundling.

https://github.com/ruby/ruby/blob/9cbb3bd1f2b05d59b6dd315ebdec295c2ced6c01/lib/webrick/webrick.gemspec#L13

It seems like a mixup happened between the branches with the 1.4.0 release.

Please fix ASAP.

Thanks!

Best regards, Thomas Balslv.





-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>