Issue #14139 has been updated by hsbt (Hiroshi SHIBATA).

Status changed from Open to Rejected

https://github.com/railsinstaller/railsinstaller-windows/issues/102 is already closed.

And this issue is same as #14047.

----------------------------------------
Bug #14139: [BUG] Segmentation fault
https://bugs.ruby-lang.org/issues/14139#change-68221

* Author: jonhue (Jonas Hbotter)
* Status: Rejected
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: ruby 2.3.3p222 (2016-11-21 revision 56859) [i386-mingw32]
* Backport: 2.3: UNKNOWN, 2.4: UNKNOWN
----------------------------------------
When running:

~~~
$ ruby test.rb
~~~

I get the following error + backtrace:

~~~
test.rb: [BUG] Segmentation fault
ruby 2.3.3p222 (2016-11-21 revision 56859) [i386-mingw32]

-- Control frame information -----------------------------------------------
c:0001 p:0000 s:0002 E:000a10 (none) [FINISH]


-- C level backtrace information -------------------------------------------
C:\WINDOWS\SYSTEM32\ntdll.dll(NtWaitForSingleObject+0xc) [0x7765E78C]
C:\WINDOWS\System32\KERNELBASE.dll(WaitForSingleObject+0x12) [0x774FEB42]
C:\RailsInstaller\Ruby2.3.3\bin\msvcrt-ruby230.dll(rb_vm_bugreport+0xaa) [0x6305F9EA]
C:\RailsInstaller\Ruby2.3.3\bin\msvcrt-ruby230.dll(rb_bug_context+0x49) [0x62F06209]
C:\RailsInstaller\Ruby2.3.3\bin\msvcrt-ruby230.dll(rb_check_safe_obj+0x394) [0x62FD0794]
 [0x00401866]
C:\WINDOWS\SYSTEM32\ntdll.dll(RtlCaptureStackContext+0x196e1) [0x776937C1]

-- Other runtime information -----------------------------------------------

* Loaded script: test.rb

* Loaded features:

    0 enumerator.so
    1 thread.rb
    2 rational.so
    3 complex.so
    4 C:/RailsInstaller/Ruby2.3.3/lib/ruby/2.3.0/i386-mingw32/enc/encdb.so
    5 C:/RailsInstaller/Ruby2.3.3/lib/ruby/2.3.0/i386-mingw32/enc/trans/transdb.so
    6 C:/RailsInstaller/Ruby2.3.3/lib/ruby/2.3.0/i386-mingw32/enc/windows_1252.so
    7 C:/RailsInstaller/Ruby2.3.3/lib/ruby/2.3.0/unicode_normalize.rb
    8 C:/RailsInstaller/Ruby2.3.3/lib/ruby/2.3.0/i386-mingw32/rbconfig.rb
    9 C:/RailsInstaller/Ruby2.3.3/lib/ruby/site_ruby/2.3.0/rubygems/compatibility.rb
   10 C:/RailsInstaller/Ruby2.3.3/lib/ruby/site_ruby/2.3.0/rubygems/defaults.rb
   11 C:/RailsInstaller/Ruby2.3.3/lib/ruby/site_ruby/2.3.0/rubygems/deprecate.rb
   12 C:/RailsInstaller/Ruby2.3.3/lib/ruby/site_ruby/2.3.0/rubygems/errors.rb
   13 C:/RailsInstaller/Ruby2.3.3/lib/ruby/site_ruby/2.3.0/rubygems/version.rb
   14 C:/RailsInstaller/Ruby2.3.3/lib/ruby/site_ruby/2.3.0/rubygems/requirement.rb
   15 C:/RailsInstaller/Ruby2.3.3/lib/ruby/site_ruby/2.3.0/rubygems/platform.rb
   16 C:/RailsInstaller/Ruby2.3.3/lib/ruby/site_ruby/2.3.0/rubygems/basic_specification.rb
   17 C:/RailsInstaller/Ruby2.3.3/lib/ruby/site_ruby/2.3.0/rubygems/stub_specification.rb
   18 C:/RailsInstaller/Ruby2.3.3/lib/ruby/site_ruby/2.3.0/rubygems/util/list.rb
   19 C:/RailsInstaller/Ruby2.3.3/lib/ruby/2.3.0/i386-mingw32/stringio.so
   20 C:/RailsInstaller/Ruby2.3.3/lib/ruby/site_ruby/2.3.0/rubygems/specification.rb
   21 C:/RailsInstaller/Ruby2.3.3/lib/ruby/site_ruby/2.3.0/rubygems/exceptions.rb
   22 C:/RailsInstaller/Ruby2.3.3/lib/ruby/2.3.0/rubygems/defaults/operating_system.rb
   23 C:/RailsInstaller/Ruby2.3.3/lib/ruby/site_ruby/2.3.0/rubygems/dependency.rb
   24 C:/RailsInstaller/Ruby2.3.3/lib/ruby/site_ruby/2.3.0/rubygems/core_ext/kernel_gem.rb
   25 C:/RailsInstaller/Ruby2.3.3/lib/ruby/2.3.0/monitor.rb
   26 C:/RailsInstaller/Ruby2.3.3/lib/ruby/site_ruby/2.3.0/rubygems/core_ext/kernel_require.rb
   27 C:/RailsInstaller/Ruby2.3.3/lib/ruby/site_ruby/2.3.0/rubygems.rb
   28 C:/RailsInstaller/Ruby2.3.3/lib/ruby/site_ruby/2.3.0/rubygems/path_support.rb
   29 C:/RailsInstaller/Ruby2.3.3/lib/ruby/site_ruby/2.3.0/rubygems/bundler_version_finder.rb
   30 C:/RailsInstaller/Ruby2.3.3/lib/ruby/site_ruby/2.3.0/rubygems/util.rb
   31 C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/gems/did_you_mean-1.0.0/lib/did_you_mean/version.rb
   32 C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/gems/did_you_mean-1.0.0/lib/did_you_mean/core_ext/name_error.rb
   33 C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/gems/did_you_mean-1.0.0/lib/did_you_mean/levenshtein.rb
   34 C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/gems/did_you_mean-1.0.0/lib/did_you_mean/jaro_winkler.rb
   35 C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/gems/did_you_mean-1.0.0/lib/did_you_mean/spell_checkable.rb
   36 C:/RailsInstaller/Ruby2.3.3/lib/ruby/2.3.0/delegate.rb
   37 C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/gems/did_you_mean-1.0.0/lib/did_you_mean/spell_checkers/name_error_checkers/class_name_checker.rb
   38 C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/gems/did_you_mean-1.0.0/lib/did_you_mean/spell_checkers/name_error_checkers/variable_name_checker.rb
   39 C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/gems/did_you_mean-1.0.0/lib/did_you_mean/spell_checkers/name_error_checkers.rb
   40 C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/gems/did_you_mean-1.0.0/lib/did_you_mean/spell_checkers/method_name_checker.rb
   41 C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/gems/did_you_mean-1.0.0/lib/did_you_mean/spell_checkers/null_checker.rb
   42 C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/gems/did_you_mean-1.0.0/lib/did_you_mean/formatter.rb
   43 C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/gems/did_you_mean-1.0.0/lib/did_you_mean.rb

[NOTE]
You may have encountered a bug in the Ruby interpreter or extension libraries.
Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html


This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.
~~~

Infact, I get the same error when calling anything that involves ruby from within the terminal.

I have installed ruby with the latest version of RailsInstaller. They have send me here: https://github.com/railsinstaller/railsinstaller-windows/issues/102

---Files--------------------------------
test.rb (3 Bytes)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>