Issue #14011 has been updated by hsbt (Hiroshi SHIBATA).

Status changed from Open to Assigned
Assignee set to normalperson (Eric Wong)

----------------------------------------
Bug #14011: Appveyor failure - svn 60172 - °∆webrick: do not hang acceptor on slow TLS connections°«
https://bugs.ruby-lang.org/issues/14011#change-67754

* Author: MSP-Greg (Greg L)
* Status: Assigned
* Priority: Normal
* Assignee: normalperson (Eric Wong)
* Target version: 
* ruby -v: ruby 2.5.0dev (2017-10-13 trunk 60172) [x64-mingw32]
* Backport: 2.3: UNKNOWN, 2.4: UNKNOWN
----------------------------------------
I noticed the recent [Appveyor failure]( https://ci.appveyor.com/project/ruby/ruby/build/1.0.5475#L4546) from [°∆webrick: do not hang acceptor on slow TLS connections°« svn 60172]( https://github.com/ruby/ruby/commit/feafe07874d3f9f9aa3fa007421ecd28472959a7).

Coincidentally, I recently tried a MinGW build with the gem puma using SSL.  It builds fine with ruby 2.2 thru trunk, but also has several [Appveyor failures]( https://ci.appveyor.com/project/MSP-Greg/puma) similar to the above, as all involve SSL servers and nonblock connections.

I°«m happy to help with testing, but I suspect this is beyond my current knowledge in terms of a fix°ń

FYI, I did run up puma locally with a static rack, http, and trunk; everything works fine.  I did not write code to connect it with multiple concurrent clients (I°«ve done that before back when I was coding in C#).  I also understand that some things may °∆just not work°« on windows.

Thanks again, Greg


---Files--------------------------------
trunk_mswin_webrick.txt (556 Bytes)
trunk_mingw_puma.txt (6.47 KB)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>