On Sun, 23 Jul 2006 nobu / ruby-lang.org wrote:

> Hi,
>
> At Sat, 22 Jul 2006 00:35:17 +0900,
> ara.t.howard / noaa.gov wrote in [ruby-core:08337]:
>> here's an example showing the abis of the c libs are not compatible:
>>
>>    Ara@windozer C:/msys/1.0/home/Ara/build/narray-0.5.8
>>    $ /c/ruby/bin/ruby -r ./narray.so -e'  p NArray  '
>>    ./narray.so: 127: The specified procedure (isacii) could not be found.   - ./narray.so (LoadError)
>>
>>
>>    Ara@windozer C:/msys/1.0/home/Ara/build/narray-0.5.8
>>    $ /c/usr/local/bin/ruby -r ./narray.so -e'  p NArray  '
>>    NArray
>
> When did you try it?  It should be fixed while ago.
>
> | Tue Jun 27 16:04:05 2006  WATANABE Hirofumi  <eban at ruby-lang.org>
> |
> |	* win32/win32.h: define isascii on MinGW for msvcrt compatibility.
> |
> |	* configure.in: set ac_cv_header_sys_time_h=no on MinGW
> |	  for msvcrt compatibility.
>
> -- 
> Nobu Nakada
>

this was a month or two ago.  yeah, i know how to fix it, i fixed it myself,
my concern is that it's up to extension writers to shoehorn these fixes into
there packages - this should be the responsibility of the c compiler/c lib and
it's subtle incompatibilities like these which make mixing vc++ and msys
binaries worrisome.

cheers.


-a
-- 
suffering increases your inner strength.  also, the wishing for suffering
makes the suffering disappear.
- h.h. the 14th dali lama