Hi,

In message "Re: [ ruby-Bugs-5036 ] Please implement expect.rb for Windows Ruby"
    on Thu, 13 Jul 2006 05:44:51 +0900, <noreply / rubyforge.org> writes:

|Adapting my scripts to not use expect.rb would be an exceptional pain.  Please implement expect.rb for Windows Ruby.

I feel sympathy for your pain.  But expect.rb highly depends on pty
which is not available on Windows.  It is nearly impossible for us to
implement it without pty.  We need to wait until some Windows expert
would write expect.rb counterpart using Win32 features.  Sorry.

							matz.