Issue #13796 has been updated by nagachika (Tomoyuki Chikanaga).

Backport changed from 2.2: DONTNEED, 2.3: DONTNEED, 2.4: REQUIRED to 2.2: DONTNEED, 2.3: DONTNEED, 2.4: DONE

ruby_2_4 r59784 merged revision(s) 59567.

----------------------------------------
Bug #13796: Please backport r59567 (openssl: import v2.0.5)
https://bugs.ruby-lang.org/issues/13796#change-66557

* Author: rhenium (Kazuki Yamaguchi)
* Status: Closed
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: 
* Backport: 2.2: DONTNEED, 2.3: DONTNEED, 2.4: DONE
----------------------------------------
This fixes the "no OPENSSL_Applink" issue on mswin builds, a bug in the PEM passphrase callback, and the test failure on Debian sid (which has removed TLS 1.0 support).



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>