Issue #13878 has been updated by nobu (Nobuyoshi Nakada).

Description updated

sasatefa2009 (Mostafa Nafady) wrote:
> ```
> /usr/local/rvm/gems/ruby-2.4.1/gems/make-0.3.1/bin/make:4:in `<top (required)>': undefined local variable or method `make' for main:Object (NameError)
> 	from /usr/local/rvm/gems/ruby-2.4.1/bin/make:23:in `load'
> 	from /usr/local/rvm/gems/ruby-2.4.1/bin/make:23:in `<main>'
> 	from /usr/local/rvm/gems/ruby-2.4.1/bin/ruby_executable_hooks:15:in `eval'
> 	from /usr/local/rvm/gems/ruby-2.4.1/bin/ruby_executable_hooks:15:in `<main>'
> no

Uninstall this broken gem.

----------------------------------------
Bug #13878: I can't install ruby on kali linux
https://bugs.ruby-lang.org/issues/13878#change-66527

* Author: sasatefa2009 (Mostafa Nafady)
* Status: Open
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: ruby 2.3.3p222 (2016-11-21) [x86_64-linux-gnu]
* Backport: 2.2: UNKNOWN, 2.3: UNKNOWN, 2.4: UNKNOWN
----------------------------------------
Greetings, 

My ruby version is ruby 2.3.3p222 (2016-11-21) [x86_64-linux-gnu]

I had multiple error while trying to install ruby in Kali-linux
"\curl -sSL https://get.rvm.io | bash -s stable --ruby"
also "rvm install ruby-2.4.1" is the same error
i recently used sudo gem cleanup before attempting to install ruby

and here is the log

```
root@kali:~# \curl -sSL https://get.rvm.io | bash -s stable --ruby
Downloading https://github.com/rvm/rvm/archive/1.29.2.tar.gz
Downloading https://github.com/rvm/rvm/releases/download/1.29.2/1.29.2.tar.gz.asc
gpg: Signature made Thu 22 Jun 2017 06:18:38 PM EET
gpg:                using RSA key E206C29FBF04FF17
gpg: Good signature from "Michal Papis (RVM signing) <mpapis / gmail.com>" [unknown]
gpg:                 aka "Michal Papis <michal.papis / toptal.com>" [unknown]
gpg:                 aka "[jpeg image of size 5015]" [unknown]
gpg: WARNING: This key is not certified with a trusted signature!
gpg:          There is no indication that the signature belongs to the owner.
Primary key fingerprint: 409B 6B17 96C2 7546 2A17  0311 3804 BB82 D39D C0E3
     Subkey fingerprint: 62C9 E5F4 DA30 0D94 AC36  166B E206 C29F BF04 FF17
GPG verified '/usr/local/rvm/archives/rvm-1.29.2.tgz'

Upgrading the RVM installation in /usr/local/rvm/
Upgrade of RVM in /usr/local/rvm/ is complete.

# Administrator,
#
#   Thank you for using RVM!
#   We sincerely hope that RVM helps to make your life easier and more enjoyable!!!
#
# ~Wayne, Michal & team.

In case of problems: https://rvm.io/help and https://twitter.com/rvm_io

Upgrade Notes:

  * It looks like some old stuff is laying around RVM, you can cleanup with: rvm cleanup all

  * No new notes to display.

Ruby enVironment Manager 1.29.2 (latest) (c) 2009-2017 Michal Papis, Piotr Kuczynski, Wayne E. Seguin

ruby-2.4.0 - #removing src/ruby-2.4.0..
Searching for binary rubies, this might take some time.
No binary rubies available for: debian/kali-rolling/x86_64/ruby-2.4.0.
Continuing with compilation. Please read 'rvm help mount' to get more information on binary rubies.
Checking requirements for debian.
Installing requirements for debian.
Updating system..
Installing required packages: libreadline6-dev..
Requirements installation successful.
Found user configured '-j' flag in 'rvm_make_flags', please note that RVM can detect number of CPU threads and set the '-j' flag automatically if you do not set it.
Installing Ruby from source to: /usr/local/rvm/rubies/ruby-2.4.0, this may take a while depending on your cpu(s)...
ruby-2.4.0 - #downloading ruby-2.4.0, this may take a while depending on your connection...
ruby-2.4.0 - #extracting ruby-2.4.0 to /usr/local/rvm/src/ruby-2.4.0....
ruby-2.4.0 - #configuring................................................................
Error running './configure --prefix=/usr/local/rvm/rubies/ruby-2.4.0 --disable-install-doc --enable-shared',
showing last 15 lines of /usr/local/rvm/log/1504758632_ruby-2.4.0/configure.log
Ignoring pcaprub-0.12.4 because its extensions are not built.  Try: gem pristine pcaprub --version 0.12.4
Ignoring pg_array_parser-0.0.9 because its extensions are not built.  Try: gem pristine pg_array_parser --version 0.0.9
Ignoring psych-2.2.4 because its extensions are not built.  Try: gem pristine psych --version 2.2.4
Ignoring rbnacl-libsodium-1.0.13 because its extensions are not built.  Try: gem pristine rbnacl-libsodium --version 1.0.13
Ignoring rdiscount-2.2.0.1 because its extensions are not built.  Try: gem pristine rdiscount --version 2.2.0.1
Ignoring redcarpet-3.4.0 because its extensions are not built.  Try: gem pristine redcarpet --version 3.4.0
Ignoring sqlite3-1.3.13 because its extensions are not built.  Try: gem pristine sqlite3 --version 1.3.13
Ignoring yajl-ruby-1.3.0 because its extensions are not built.  Try: gem pristine yajl-ruby --version 1.3.0
/usr/local/rvm/gems/ruby-2.4.1/gems/make-0.3.1/bin/make:4:in `<top (required)>': undefined local variable or method `make' for main:Object (NameError)
	from /usr/local/rvm/gems/ruby-2.4.1/bin/make:23:in `load'
	from /usr/local/rvm/gems/ruby-2.4.1/bin/make:23:in `<main>'
	from /usr/local/rvm/gems/ruby-2.4.1/bin/ruby_executable_hooks:15:in `eval'
	from /usr/local/rvm/gems/ruby-2.4.1/bin/ruby_executable_hooks:15:in `<main>'
no
checking for safe null command for make... configure: error: no candidate for safe null command
There has been an error while running configure. Halting the installation.



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>