Issue #13865 has been updated by wyhaines (Kirk Haines).

Status changed from Open to Closed

Per your request, I have closed this.

----------------------------------------
Bug #13865: Triggered segfault, on Ruby2.4/OSX.
https://bugs.ruby-lang.org/issues/13865#change-66492

* Author: 0xab (0xAB .)
* Status: Closed
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: ruby 2.4.1p111 (2017-03-22 revision 58053) [x86_64-darwin15]
* Backport: 2.2: UNKNOWN, 2.3: UNKNOWN, 2.4: UNKNOWN
----------------------------------------
Hi.

I ran into a segmentation fault, the reproduction steps are here:

$ git clone https://github.com/r-obert/pry-plusplus.git
$ cd pry-plusplus
$ git checkout edf3496f425ef2512431a79b72a2a5fd930b2fcf
$ gem install bundler --no-rdoc --no-ri
$ bundle install
$ rake pry # or: ruby -Ilib bin/pry
pry(main)> \_pry\_.h.deprecate_method! Object.methods.map{|m| Object.method(m) }, "everything is deprecated"
zsh: segmentation fault  rake pry

Sorry, I have not reduced further. Could this be an exception instead, so I can see what is wrong? Thanks.




-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>