Hi,

In <BE04AE19-BBB8-4EB5-A064-4A4CF3CC7DA0 / segment7.net>
  "Re: rss patch -- mostly doc, plus English adjustments." on Fri, 14 Jul 2006 03:38:07 +0900,
  Eric Hodel <drbrain / segment7.net> wrote:

> On Jul 13, 2006, at 4:38 AM, Kouhei Sutou wrote:
> 
> > In <Pine.GSO.4.64.0607121836100.17386 / brains.eng.cse.dmu.ac.uk>
> >   "rss patch -- mostly doc, plus English adjustments." on Thu, 13  
> > Jul 2006 02:50:53 +0900,
> >   Hugh Sasse <hgs / dmu.ac.uk> wrote:
> >
> >> --- ./lib/rss/dublincore.rb.orig	2006-06-20 12:50:52.000000000 +0100
> >> +++ ./lib/rss/dublincore.rb	2006-07-12 18:34:58.990946000 +0100
> >> @@ -61,7 +61,10 @@
> >>        "language" => nil,
> >>        "relation" => nil,
> >>        "coverage" => nil,
> >> -      "rights" => "rightses" # FIXME
> >> +      "rights" => "rights"   # <FIXME> this refers to a set of  
> >> management rights
> >> +                             # If you add more rights it remains  
> >> plural.
> >> +                             # I can't see anywhere that these  
> >> names must be
> >> +                             # distinct. "deer" => "deer" etc. </ 
> >> FIXME>
> >>      }
> >
> > I rejected the above changes. Because this changes breaks
> > backward compatibility.
> 
> Could this be applied just to HEAD?

No. This changes have two problems. First is that breaks
backward compatibility. Second is that removes convenience
method (obj.dc_rights == obj.dc_rightses[0]).

I have an idea that renaming rightses to rights_values and
providing an alias rightses as rights_values. But I don't
like the name rights_values...


Thanks,
--
kou