Issue #12733 has been updated by hsbt (Hiroshi SHIBATA).


I've added `make test-bundler` task to the ruby core. 

see https://github.com/ruby/ruby/pull/1536

Maybe, I tested this patch with macOS only. Probably the following task is not compatible all of the supported platform.

https://github.com/ruby/ruby/pull/1536/files#diff-7e056ddc530791272d363e50c1f25647R488

I found problems with bundler test suite before `make install`environment.

1. Tests of `bundle install` with native extensions relied on installed ruby interpreter.
2. Tests of °»default gems°… are failed. Because they are not installed before `make install`
3. Tests of °»bundler exec°… with gem installed Gemfile relied on installed ruby interpreter.(ex. shebang of rack command use it)
4. bundler tests require °»groff°… command for man verification. ruby core could not prepare it.
5. Some tests depend on the directory structure of bundler/bundler.

I omitted or added workaround to theirs.

https://github.com/hsbt/ruby/blob/e16f39690e2e7843690f691e9f68e3371aba96f3/spec/bundler.patch

I have a happy news. `make test-bundler` results is here

2269 examples, 0 failures, 3 pending

I ignored 40 examples. but I got green results of most all of examples.


----------------------------------------
Feature #12733: Bundle bundler to ruby core
https://bugs.ruby-lang.org/issues/12733#change-65957

* Author: hsbt (Hiroshi SHIBATA)
* Status: Assigned
* Priority: Normal
* Assignee: hsbt (Hiroshi SHIBATA)
* Target version: 2.5
----------------------------------------
rubygems team has plan to migrate bundler into rubygems at rubygems 3.0.

ref. https://github.com/rubygems/rubygems/issues/1681

In current status, rubygems only use `Bundler` module on test suites.
But we should track rubygems upstream step by step. I propose to bundle bundler
for stdlib as default gem on ruby core repository.

but we have some consideration. such as

 * bundler uses rspec for test suites. How to use rspec on ruby core repository?
 * Who are maintain bundler on ruby core repository?

This issue is epic topic. Please comment your concerns or idea. 



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>