Issue #13573 has been updated by shyouhei (Shyouhei Urabe).


I think Ruby 2.4.x on Mac 10.5.x is not a supported combination.  The proposed patch _seems_ fine though.  I no longer own a PPC Mac so cannot test it.

----------------------------------------
Bug #13573: Compilation on Mac OS X 10.5.8 fails because of missing _fgetattrlist
https://bugs.ruby-lang.org/issues/13573#change-64886

* Author: takashiyoshi (Takashi Yoshi)
* Status: Open
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: ruby 2.4.1p111 (2017-03-22 revision 58053) [universal.powerpc64-darwin9.0]
* Backport: 2.2: UNKNOWN, 2.3: UNKNOWN, 2.4: UNKNOWN
----------------------------------------
When compiling Ruby 2.3.x and 2.4.x on Mac OS X 10.5.8, compilation fails with:

~~~
linking miniruby
Undefined symbols for architecture ppc:
  "_fgetattrlist", referenced from:
      _glob_helper in dir.o
ld: symbol(s) not found for architecture ppc
collect2: ld returned 1 exit status
Undefined symbols for architecture ppc64:
  "_fgetattrlist", referenced from:
      _glob_helper in dir.o
ld: symbol(s) not found for architecture ppc64
collect2: ld returned 1 exit status
~~~

The issue is similar to #11054.
The fgetattrlist function is missing on Mac OS X 10.5.8

Applying the attached patch fixes the problem and then Ruby 2.4.1 builds successfully.

---Files--------------------------------
ruby24-fgetattrlist.diff (1.11 KB)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>