Issue #13559 has been updated by shyouhei (Shyouhei Urabe).


Well, I know everyone don't like the name yield_self but, it seems that's a separate issue than this one.  Can we focus?  I guess we need another 5 years to find an "ideal" name of it and that's too off topic to what is requested here.

----------------------------------------
Feature #13559: Change implementation of Feature #6721
https://bugs.ruby-lang.org/issues/13559#change-64859

* Author: dunrix (Damon Unrix)
* Status: Feedback
* Priority: Normal
* Assignee: 
* Target version: 
----------------------------------------
Hi,

please reconsider implementation of feature request #6721 planned for Ruby 2.5.0 .

Instead of introducing new method `Object#yield_self`, just reuse existing `Object#itself` by taking an optional block argument.

Find it much clearer and more logical solution, not superfluous polluting of API space.
`Object#itself` just returns target object, optional block would return alternative value with target object passed as block argument.

Prototyped sol. in Ruby:

~~~ruby
class Object
  def itself
    block_given? ? yield(self) : self
  end
end
~~~

Not aware of any case, where it would break backward compatibility.




-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>