Issue #13395 has been updated by sawa (Tsuyoshi Sawada).


Many methods that take a block come in positive-negative pairs, unlike `count`. I am not sure how frequent the use case is, but if it is, I rather claim that there should be a negative version of `count`.

----------------------------------------
Feature #13395: Add a method to check for not nil
https://bugs.ruby-lang.org/issues/13395#change-64040

* Author: JustJosh (Joshua Stowers)
* Status: Open
* Priority: Normal
* Assignee: 
* Target version: 
----------------------------------------
There does not seem to be a method in Ruby to check if an object is *not* nil.
Such a method could help with readability.

Example:
> ~~~ ruby
> array = [1, 'dog', nil]
> array.count(&:not_nil?)
> ~~~

> vs

> ~~~ ruby
> array = [1, 'dog', nil]
> array.reject(&:nil?).count
> ~~~





-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>