Issue #13267 has been updated by Nobuyoshi Nakada.

Description updated
Backport changed from 2.2: UNKNOWN, 2.3: UNKNOWN, 2.4: UNKNOWN to 2.2: REQUIRED, 2.3: REQUIRED, 2.4: REQUIRED

----------------------------------------
Bug #13267: ruby 2.4.0 i686-w64-mingw32 + boost compilation error
https://bugs.ruby-lang.org/issues/13267#change-63318

* Author: Marty Plummer
* Status: Closed
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: ruby-2.4.0.tar.xz (mingw, can't run ruby directly)
* Backport: 2.2: REQUIRED, 2.3: REQUIRED, 2.4: REQUIRED
----------------------------------------
When building https://github.com/Ancurio/mkxp for windows (via i686-w64-mingw32), the following build error occurs:

```
In file included from /usr/i686-w64-mingw32/include/ruby-2.4.0/ruby/defines.h:243:0,
                 from /usr/i686-w64-mingw32/include/ruby-2.4.0/ruby/ruby.h:36,
                 from /usr/i686-w64-mingw32/include/ruby-2.4.0/ruby.h:33,
                 from mkxp/binding-mri/binding-util.h:25,
                 from mkxp/binding-mri/binding-mri.cpp:23:
/usr/i686-w64-mingw32/include/boost/functional/hash/detail/float_functions.hpp: In member function 'Float boost::hash_detail::call_frexp<Float>::operator()(Float, int*) const':
/usr/i686-w64-mingw32/include/ruby-2.4.0/ruby/win32.h:759:23: error: expected unqualified-id before '__extension__'
 #define frexp(_X, _Y) __extension__ ({\
                       ^
/usr/i686-w64-mingw32/include/ruby-2.4.0/ruby/win32.h:759:23: error: expected ';' before '__extension__'
```



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>