Issue #5555 has been updated by Marcus Stollsteimer.


Steve Bachmair wrote:
> Then we could just write whatever is most readable in a given circumstance (which will usually be the third-person form).

I just wanted to point out that "usual" depends: I almost always use names in pluralized form for arrays or hashes, like `files`, `users`, `options`, ..., instead of `list`, `my_hash`, or similar. And `colors.includes?` reads at least as bad as `line.start_with?`. (So, _renaming_ those methods - which is what this issue is about - would not really help).

----------------------------------------
Feature #5555: rename #include? to #includes?
https://bugs.ruby-lang.org/issues/5555#change-62929

* Author: Alexey Muranov
* Status: Rejected
* Priority: Normal
* Assignee: Yukihiro Matsumoto
* Target version: 
----------------------------------------
Shouldn't the #include? method be renamed to #includes? ?
I think this will be closer to correct English and consistent with #has_key? method (not #have_key?).



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>