Issue #12956 has been updated by Tomoyuki Chikanaga.

Backport changed from 2.1: REQUIRED, 2.2: DONE, 2.3: REQUIRED to 2.1: REQUIRED, 2.2: DONE, 2.3: DONE

ruby_2_3 r57344 merged revision(s) 56832.

----------------------------------------
Bug #12956: require a native library that yields the error 'incompatiable library version' shuts down the interpreter fatally
https://bugs.ruby-lang.org/issues/12956#change-62502

* Author: Christian Köstlin
* Status: Closed
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: ruby 2.3.2p217 (2016-11-15 revision 56796) [x86_64-darwin16]
* Backport: 2.1: REQUIRED, 2.2: DONE, 2.3: DONE
----------------------------------------
I would like to rescue from this in ruby-code.
Looking at the source in dln.c around line 1334 shows, that there is a special APPLE define with a comment that suggests, that properly cleaning up with dlclose crashes.
Disabling the special handling on my machine running OSX Sierra 10.12.1 did not show the crashing behavior, but instead I was able to rescue from the LoadError.
To reproduce I attached my native extension. To reproduce this just run irb -I. and require 'dotstar'


---Files--------------------------------
dotstar.bundle (208 KB)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>