Issue #13032 has been updated by Steve Wills.


This looks to be a recurrence of bug 10161, which was created by r43888 then reverted in r47248 and now triggered again in r56670.

----------------------------------------
Bug #13032: building capi docs with doxygen seems broken in 2.4-rc1
https://bugs.ruby-lang.org/issues/13032#change-62023

* Author: Steve Wills
* Status: Open
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: ruby 2.4.0rc1 (2016-12-12 trunk 57064) [amd64-freebsd12]
* Backport: 2.1: UNKNOWN, 2.2: UNKNOWN, 2.3: UNKNOWN
----------------------------------------
When building 2.4-rc1 with the --enable-install-capi option passed to configure, I get lots of messages of this form:

~~~
Version of /wrkdirs/usr/ports/lang/ruby24/work/ruby-2.4.0-rc1/id.c : /wrkdirs/usr/ports/lang/ruby24/work/ruby-2.4.0-rc1/.ext/common/date.rb:4:in `require': cannot load such file -- date_core (Lo
adError)
        from /wrkdirs/usr/ports/lang/ruby24/work/ruby-2.4.0-rc1/.ext/common/date.rb:4:in `<top (required)>'
        from /wrkdirs/usr/ports/lang/ruby24/work/ruby-2.4.0-rc1/lib/time.rb:3:in `require'
        from /wrkdirs/usr/ports/lang/ruby24/work/ruby-2.4.0-rc1/lib/time.rb:3:in `<top (required)>'
        from /wrkdirs/usr/ports/lang/ruby24/work/ruby-2.4.0-rc1/tool/vcs.rb:3:in `require'
        from /wrkdirs/usr/ports/lang/ruby24/work/ruby-2.4.0-rc1/tool/vcs.rb:3:in `<top (required)>'
        from ./tool/file2lastrev.rb:10:in `require'
        from ./tool/file2lastrev.rb:10:in `<main>'
no version available
~~~

Note that this is with no version of ruby yet installed on the system.



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>