> You have to understand that environment variables are in fact insecure.  It is a very bad idea to store passwords there.  Surprising or not, insecure is insecure.  We shall not introduce this.

Well, less point this to me. Since  r54432, open-uri uses
ENV['http-proxy']. You don't talk about ruby's policy.
This ticket is less point too. http-proxy is useful for command-line
utilities. Why don't you use open-uri?

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>