On 2016/11/07 17:53, funny.falcon / gmail.com wrote:
> You've measured latest Vlad's version, but not latest mine.

There are several reasons:

(1) Your last version is not open addressing.
    It is hard to compare many evaluation points.
    This was main reason.

(2) You mentioned that chained version will increase memory usage.
    At this time (before Ruby 2.4), we need to decide
    (maybe this is last chance to merge),
    so I decide to see memory usage more for Ruby 2.4.

(3) Your patch is not on github, but with an attached patch.
    It is slightly tough for me.
    (I made a script to build ruby on svn/git branch)

(4) I measured them last week and I have no plenty time.
    (this is why I post this update version today)


(3) and (4) is not fair reason. Only because my laziness (if I had
shorten my sleeping time, I could do).

I hope my report will help next improvements.

-- 
// SASADA Koichi at atdot dot net


Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>