Issue #12830 has been updated by Vit Ondruch.


Ok, so now we have openssl-1.1.0b-3.fc26 as well as compat-openssl10-1.0.2j-5.fc26 on Fedora Rawhide, so it should be possible to build older Ruby, but unfortunately, some other libraries fails, since they loads both versions of OpenSSL into memory. For example rubygem Ethon fails to pass its test suite (see [1] or build.log from [2] if the first link does not work anymore). Is there any chance to make openssl.so to load correctly versioned libssl.so?





[1]: https://kojipkgs.fedoraproject.org//packages/ruby/2.3.1/58.fc26/data/logs/x86_64/build.log
[2]: https://apps.fedoraproject.org/koschei/package/rubygem-typhoeus?collection=f26

----------------------------------------
Bug #12830: OpenSSL 1.1.0+ support?
https://bugs.ruby-lang.org/issues/12830#change-60978

* Author: Vit Ondruch
* Status: Assigned
* Priority: Normal
* Assignee: Kazuki Yamaguchi
* ruby -v: ruby 2.3.1p112 (2016-04-26 revision 54768) [x86_64-linux]
* Backport: 2.1: UNKNOWN, 2.2: UNKNOWN, 2.3: UNKNOWN
----------------------------------------
What is the plan with OpenSSL 1.1.0+ support? I am asking, since per this announcement [1], the OpenSSL 1.1.0 landed today in Fedora Rawhide and Ruby CI immediately failed [2], [3]. I see that there is some upstream work on OpenSSL support [4], but I am wondering how this will be handled for stable Ruby releases?


[1]: https://lists.fedoraproject.org/archives/list/devel / lists.fedoraproject.org/thread/EXLYHY6ZXH65IQXKMPE6XHPNTL45MO4Y/
[2]: https://apps.fedoraproject.org/koschei/package/ruby?collection=f26
[3]: https://kojipkgs.fedoraproject.org/work/tasks/6543/16046543/build.log
[4]: https://github.com/ruby/openssl



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>