Hi,

In message "Re: Extensions for Time and ParseDate"
    on 03/01/23, Mathieu Bouchard <matju / sympatico.ca> writes:

|> Ryan, I also fixed EWOULDBLOCK problem.  I will commit them soon.
|
|May I know what that problem is? I'm curious, because two of my
|libraries depend on nonblocking I/O (GridFlow, RubyX11).

1.6.8 and 1.8.0 does not provide duplicated error constants, so that
when EAGAIN == EWOULDBLOCK, there's no Errno::EWOULDBLOCK defined.

Besides we have to work on increasing portability here (error names
and their numbers are platform dependant), but I have no good idea
yet.

							matz.