Issue #12725 has been updated by Martin Drst.

File bug12725.txt added
Subject changed from Trying to to Trying to use ./miniruby before it exists
Assignee set to Nobuyoshi Nakada
ruby -v set to ruby 2.4.0dev (2016-09-05 trunk 56071) [x86_64-cygwin]

When trying to compile ruby from a fresh checkout, with the Unicode version changed to 9.0.0, I get the following error:

```
./miniruby.exe -I./lib -I. -I.ext/common  ./tool/enc-unicode.rb --header ./enc/unicode/data/9.0.0 > enc/unicode/9.0.0/name2ctype.h
/bin/sh: ./miniruby.exe: No such file or directory
make[1]: *** [uncommon.mk:1110: enc/unicode/9.0.0/name2ctype.h] Error 127
make[1]: Leaving directory '/cygdrive/c/Data/ruby_test9'
make: *** [uncommon.mk:1104: enc/unicode/9.0.0/name2ctype.h] Error 2
```

./miniruby.exe is not yet available, but there is an attempt to use it. I think the solution is to either use base ruby here, or to delay the production of the files derived from Unicode data files to a later stage.

I do not get this error from a preexisting checkout, obviously because ./miniruby already exists. But this problem should also affect continuous integration, unless it is for some reason cygwin-specific.

I'm attaching a configuration summary and the full make output.

I apologize for having pressed the submit button erroneously when I barely started writing this bug report.

----------------------------------------
Bug #12725: Trying to use ./miniruby before it exists
https://bugs.ruby-lang.org/issues/12725#change-60371

* Author: Martin Drst
* Status: Open
* Priority: Normal
* Assignee: Nobuyoshi Nakada
* ruby -v: ruby 2.4.0dev (2016-09-05 trunk 56071) [x86_64-cygwin]
* Backport: 2.1: UNKNOWN, 2.2: UNKNOWN, 2.3: UNKNOWN
----------------------------------------


---Files--------------------------------
bug12725.txt (6.08 KB)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>