Issue #12707 has been updated by Vit Ondruch.

Status changed from Open to Closed

I don't observer this issue anymore. This was probably part of the issues resolved in #12681.

----------------------------------------
Bug #12707: Ripper is not built due to missing bison
https://bugs.ruby-lang.org/issues/12707#change-60337

* Author: Vit Ondruch
* Status: Closed
* Priority: Normal
* Assignee: 
* ruby -v: ruby 2.4.0dev (2016-08-25 trunk 56008) [x86_64-linux]
* Backport: 2.1: UNKNOWN, 2.2: UNKNOWN, 2.3: UNKNOWN
----------------------------------------
Bison was never required to build Ruby from the source tarball. But now (testing with snapshot of r 56008) it seems that Ripper requires Bison to be available:

```
*** Following extensions failed to configure:
../.././ext/ripper/extconf.rb:10: missing bison; abort
*** Fix the problems, then remove these directories and try again if you want.
```

Is this intentional?



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>