Issue #12680 has been updated by Tomoyuki Chikanaga.

Backport changed from 2.1: UNKNOWN, 2.2: REQUIRED, 2.3: REQUIRED to 2.1: UNKNOWN, 2.2: REQUIRED, 2.3: DONE

Thank you for your great work!
The patches are applied on ruby_2_3 branch at r56018.

----------------------------------------
Bug #12680: Please backport memory leak fixes in ext/openssl
https://bugs.ruby-lang.org/issues/12680#change-60300

* Author: Kazuki Yamaguchi
* Status: Closed
* Priority: Normal
* Assignee: 
* ruby -v: 
* Backport: 2.1: UNKNOWN, 2.2: REQUIRED, 2.3: DONE
----------------------------------------
The following methods have an issue of memory leak:

- OpenSSL::X509::ExtensionFactory#create_ext
- OpenSSL::X509::ExtensionFactory#config=
- OpenSSL::X509::Extension#oid=
- OpenSSL::X509::Extension#value=
- OpenSSL::X509::Attribute#oid=
- OpenSSL::X509::Request#set_attributes, #add_attribute
- OpenSSL::X509::Revoked#set_extensions, #add_extension
- OpenSSL::PKCS12.create
- OpenSSL::PKey::EC#export
- OpenSSL::PKCS7#verify
- OpenSSL::PKCS7#add_data

They are fixed on GitHub ruby/openssl but they all exist in stable branches.

Here are the fixing commits:

https://github.com/ruby/openssl/compare/3a2840e80d275895523a526ce56e4f6e7b8f9cc4...1e30cd395b14ef46e04bdd9ab72f10067890b265

Or please use the attached patch that applies on top of ruby_2_3 branch if preferred.

---Files--------------------------------
patches-ruby-2-3.tar.gz (6.69 KB)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>