Issue #12681 has been updated by Vit Ondruch.


Hiroshi SHIBATA wrote:
> >Also, the "gem install tk" does not build the extension, so that is another source of possible issues.
> 
> I missed configuration of tk.gemspec. It's fixed at tk-0.1.1 probably. Can you confirm it?

Yes, the 0.1.1 looks good. Thx.

----------------------------------------
Bug #12681: Gemfied tk issue
https://bugs.ruby-lang.org/issues/12681#change-60280

* Author: Vit Ondruch
* Status: Closed
* Priority: Normal
* Assignee: Yui NARUSE
* ruby -v: ruby 2.4.0dev (2016-08-16 trunk 55915) [x86_64-linux]
* Backport: 2.1: UNKNOWN, 2.2: UNKNOWN, 2.3: UNKNOWN
----------------------------------------
First of all, thank you for moving Tk into independent gem.

Nevertheless, I have one concern. So far, you left the tcltklib.so and tkutil.so under ruby lib directory. This is unfortunately major flaw, since the Tk gem is not one of the default gems. Hence, if you install more versions of Tk library, there might be collision among them.

Also, the "gem install tk" does not build the extension, so that is another source of possible issues.





-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>