Issue #12512 has been updated by Rodrigo Rosenfeld Rosas.


Yes, I would say the same a few days ago about map_v being a bad name... I also prefer map_values. I just didn't say anything because I prefer a map_v over not having such a method at all and didn't want to delay this feature :P

----------------------------------------
Feature #12512: Import Hash#transform_values and its destructive version from ActiveSupport
https://bugs.ruby-lang.org/issues/12512#change-60049

* Author: Kenta Murata
* Status: Closed
* Priority: Normal
* Assignee: Kenta Murata
----------------------------------------
I think value transformation is a fundamental feature of Hash.



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>