Issue #12512 has been updated by Benoit Daloze.


Yukihiro Matsumoto wrote:
> `#map_v` accepted.
> 
> Matz.

Will all due respect,
I think the name #map_v is not very Ruby-like.
Why such a short name?

#map_values seems more consistent with existing methods (#values, #values_at, #each_value, #has_value?, #value?).
It also conveys the intention explicitly, while I am fairly certain many people will be confused by #map_v.
From the documentation and standard terminology: "A Hash is a dictionary-like collection of unique keys and their values.".
Most of the duplicated tickets also mentioned #map_values and I believe this is the name most people would expect.
The discussion in https://bugs.ruby-lang.org/issues/7793 also converges towards #map_values (even nobu agreed :) ).

Matz, could you please reconsider the name?

----------------------------------------
Feature #12512: Import Hash#transform_values and its destructive version from ActiveSupport
https://bugs.ruby-lang.org/issues/12512#change-60047

* Author: Kenta Murata
* Status: Closed
* Priority: Normal
* Assignee: Kenta Murata
----------------------------------------
I think value transformation is a fundamental feature of Hash.



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>