Issue #9023 has been updated by Dmitriy Non.


Bozhidar Batsov wrote:
> I also dislike the name Array#tail, since it's commonly associated with linked lists, not arrays.

+1 on that.

Bozhidar Batsov wrote:
> I think a much better name would be Array#butfirst (and I've actually renamed Array#tail in powerpack to Array#butfirst)

Why do you and Matz not like #but_first ? Doesn't that make more sense to split words? #is_a? 
I knew not much of methods that doesn't split words (actually I can remember only #upto and #downto)




----------------------------------------
Feature #9023: Array#tail
https://bugs.ruby-lang.org/issues/9023#change-59802

* Author: Fuad Saud
* Status: Assigned
* Priority: Normal
* Assignee: Yukihiro Matsumoto
----------------------------------------
I propose the addition of a `tail` method to the Array class that returns all elements but the first. It is a pretty common pattern in functional programming, but not limited to - I use it extensively in all kinds of apps/gems. The implementation would be pretty trivial, I won't risk a patch to MRI because I'm uninitiated on ruby core matters, but powerpack gem (http://github.com/bbatsov/powerpack) implements it in ruby in terms of slices.




-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>