Issue #6227 has been updated by Tsuyoshi Morita.


I confirmed that this issue is no longer exist in the current RubyInstaller build versions.

I checked below versions.
 ruby 2.0.0p648 (2015-12-16) [i386-mingw32]
 ruby 2.0.0p648 (2015-12-16) [x64-mingw32]
 ruby 2.3.0p0 (2015-12-25 revision 53290) [i386-mingw32]
 ruby 2.3.0p0 (2015-12-25 revision 53290) [x64-mingw32]

~~~
ex:

sh-3.1$ ruby --version
ruby 2.0.0p648 (2015-12-16) [i386-mingw32]

sh-3.1$ ruby -ropenssl -e 'puts OpenSSL::OPENSSL_VERSION'
OpenSSL 1.0.1l 15 Jan 2015

sh-3.1$ make test-all TESTS='openssl fiddle psych zlib io json mkmf pathname 
stringio erb fileutils ruby/test_io.rb ruby/test_io_m17n.rb ruby/test_file.rb 
--hide-skip -v' | tee test-all-specific.log

...

Finished tests in 81.198084s, 26.9464 tests/s, 148.0207 assertions/s.

2188 tests, 12019 assertions, 0 failures, 0 errors, 17 skips

sh-3.1$ grep test_multibyte_read_write test-all-specific.log
OpenSSL::TestSSL#test_multibyte_read_write = 0.13 s = .

~~~

----------------------------------------
Bug #6227: [mingw] openssl backport causing test error
https://bugs.ruby-lang.org/issues/6227#change-59474

* Author: Jon Forums
* Status: Feedback
* Priority: Normal
* Assignee: openssl
* ruby -v: ruby 1.9.3p172 (2012-03-30 revision 35179) [i386-mingw32]
* Backport: 
----------------------------------------
On Win7 32bit built with MinGW GCC 4.6.2 and the RubyInstaller build recipes, the following error occurs:


sh-3.1$ ruby --version
ruby 1.9.3p172 (2012-03-30 revision 35179) [i386-mingw32]

sh-3.1$ ruby -ropenssl -e 'puts OpenSSL::OPENSSL_VERSION'
OpenSSL 1.0.0h 12 Mar 2012

sh-3.1$ make test-all TESTS='openssl fiddle psych zlib io json mkmf pathname stringio erb 
fileutils ruby/test_io.rb ruby/test_io_m17n.rb ruby/test_file.rb'

  1) Error:
test_multibyte_read_write(OpenSSL::TestSSL):
OpenSSL::SSL::SSLError: SSL_read:: internal error
    c:/projects/rubyinstaller-git/sandbox/ruby19_build/.ext/common/openssl/buffering.rb:53:in `sysread'
    c:/projects/rubyinstaller-git/sandbox/ruby19_build/.ext/common/openssl/buffering.rb:53:in `fill_rbuff'
    c:/projects/rubyinstaller-git/sandbox/ruby19_build/.ext/common/openssl/buffering.rb:94:in `read'
    c:/Users/Jon/Documents/RubyDev/ruby-git/test/openssl/test_ssl.rb:407:in `block (2 levels) in test_multibyte_read_write'
    c:/Users/Jon/Documents/RubyDev/ruby-git/test/openssl/utils.rb:235:in `call'
    c:/Users/Jon/Documents/RubyDev/ruby-git/test/openssl/utils.rb:235:in `block (2 levels) in server_loop'



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>