Issue #12325 has been updated by Hiroshi SHIBATA.

Status changed from Open to Feedback

Please try with Ruby 2.2.5 or 2.3.1

----------------------------------------
Bug #12325: Ruby 2.2.1 fails with Rails 4.2.0-6 - Segmentation fault at 0x00000000000418 ruby 2.2.1p85
https://bugs.ruby-lang.org/issues/12325#change-58882

* Author: Doug Wright
* Status: Feedback
* Priority: Normal
* Assignee: 
* ruby -v: 2.2.1
* Backport: 2.1: UNKNOWN, 2.2: UNKNOWN, 2.3: UNKNOWN
----------------------------------------
I am pretty sure this is not a Rails error. 
Ruby 2.1.2 works fine. With Ruby 2.2.1, I cannot run rake db:migrate or any rake/db commands.

Error log attached, and partially below:

/Users/dwright/.rvm/gems/ruby-2.2.1/gems/debug_inspector-0.0.2/lib/debug_inspector.bundle: [BUG] Segmentation fault at 0x00000000000418
ruby 2.2.1p85 (2015-02-26 revision 49769) [x86_64-darwin14]


-- Machine register context ------------------------------------------------
 rax: 0x0000000000000030 rbx: 0x000000010dbf2f08 rcx: 0x0000000000000000
 rdx: 0xfffffffffffffff0 rdi: 0x0000000000000030 rsi: 0x0000000000000000
 rbp: 0x00007fff52ffcbc0 rsp: 0x00007fff52ffcbc0  r8: 0x000000000000000b
  r9: 0x00000000e0000000 r10: 0x0000000000000a58 r11: 0x00007fff82004c40
 r12: 0x00007fff72641070 r13: 0x00007fee89d07430 r14: 0x0000000000000006
 r15: 0x00007fff52ffcc50 rip: 0x000000010dc3549f rfl: 0x0000000000010246

-- C level backtrace information -------------------------------------------
0   ruby                                0x000000010ceb698b rb_vm_bugreport + 155
1   ruby                                0x000000010cd5ae80 rb_bug_context + 480
2   ruby                                0x000000010ce332f3 sigsegv + 83
3   libsystem_platform.dylib            0x00007fff82003f1a _sigtramp + 26
4   libruby.2.0.0.dylib                 0x000000010dc3549f ruby_xmalloc + 17
5   ???                                 0x00007fff52ffcbe0 0x0 + 140734585883616

-- Other runtime information -----------------------------------------------

* Loaded script: /Users/dwright/.rvm/gems/ruby-2.2.1/bin/rake

---Files--------------------------------
ruby_2016-04-27-111440_doog.crash (36 KB)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>