Issue #12385 has been reported by Martin Drst.

----------------------------------------
Bug #12385: xmlrpc requires Ruby version >= 2.4.0., and produces an error even though I have Ruby 2.4.0
https://bugs.ruby-lang.org/issues/12385

* Author: Martin Drst
* Status: Open
* Priority: Normal
* Assignee: Nobuyoshi Nakada
* ruby -v: ruby 2.4.0dev (2016-05-16 trunk 55016) [x86_64-cygwin]
* Backport: 2.1: UNKNOWN, 2.2: UNKNOWN, 2.3: UNKNOWN
----------------------------------------
With
```
make up; make install-nodoc
```
I get the error below. There are two issues with this:
1) I have Ruby 2.4.0, so it's very unclear why this should produce an error
2) xmlrpc has been around for a long time, and older versions of xmlrpc should work fine with older versions of Ruby, so the error message should say which version of xmlrpc it is that needs Ruby >= 2.4.4

```
installing bundle gems:       /usr/local/lib/ruby/gems/2.4.0 (build_info, cache, doc, extensions, gems, specifications)
                              did_you_mean-1.0.0.gem
                              minitest-5.8.4.gem
                              net-telnet-0.1.1.gem
                              power_assert-0.2.7.gem
                              rake-11.1.2.gem
                              test-unit-3.1.8.gem
/cygdrive/c/Data/ruby/lib/rubygems/installer.rb:605:in `ensure_required_ruby_version_met': xmlrpc requires Ruby version >= 2.4.0. (Gem::InstallError)
        from /cygdrive/c/Data/ruby/lib/rubygems/installer.rb:821:in `pre_install_checks'
        from /cygdrive/c/Data/ruby/lib/rubygems/installer.rb:279:in `install'
        from ./tool/rbinstall.rb:685:in `call'
        from ./tool/rbinstall.rb:685:in `block in <class:Installer>'
        from /cygdrive/c/Data/ruby/lib/rubygems/resolver/specification.rb:97:in `install'
        from /cygdrive/c/Data/ruby/lib/rubygems/request_set.rb:260:in `block in install_into'
        from /cygdrive/c/Data/ruby/lib/rubygems/request_set.rb:252:in `each'
        from /cygdrive/c/Data/ruby/lib/rubygems/request_set.rb:252:in `install_into'
        from /cygdrive/c/Data/ruby/lib/rubygems/request_set.rb:148:in `install'
        from /cygdrive/c/Data/ruby/lib/rubygems/dependency_installer.rb:405:in `install'
        from /cygdrive/c/Data/ruby/lib/rubygems.rb:607:in `install'
        from ./tool/rbinstall.rb:765:in `block (2 levels) in <main>'
        from ./tool/rbinstall.rb:764:in `each'
        from ./tool/rbinstall.rb:764:in `block in <main>'
        from ./tool/rbinstall.rb:800:in `block in <main>'
        from ./tool/rbinstall.rb:797:in `each'
        from ./tool/rbinstall.rb:797:in `<main>'
uncommon.mk:268: recipe for target 'do-install-nodoc' failed
make: *** [do-install-nodoc] Error 1
```



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>