Issue #12233 has been updated by Usaku NAKAMURA.

Backport changed from 2.1: REQUIRED, 2.2: REQUIRED, 2.3: DONE to 2.1: REQUIRED, 2.2: DONE, 2.3: DONE

ruby_2_2 r54678 merged revision(s) 54444.

----------------------------------------
Bug #12233: Please consider adding documentation to DateTime, one line, require 'date'
https://bugs.ruby-lang.org/issues/12233#change-58213

* Author: Robert A. Heiler
* Status: Closed
* Priority: Normal
* Assignee: 
* ruby -v: 
* Backport: 2.1: REQUIRED, 2.2: DONE, 2.3: DONE
----------------------------------------
The ruby DateTime page does not include this line:

   require 'date'

It just happened on IRC right now (I edited/truncated a bit here):

    <schemanic> Can anyone tell me why in irb Date/Time/DateTime gives me NameError: uninitialized constant DateTime
    <apeiros> schemanic: because you forgot to require 'date'?
    <apeiros> though, Time in that list won't give you a NameError
    <schemanic> sigh. Okay. I'm sorry - the Ruby doc code example didn't have the requirement statement


The documentation can be found here:

    http://ruby-doc.org/stdlib/libdoc/date/rdoc/DateTime.html
    http://ruby-doc.org/stdlib-2.3.0/libdoc/date/rdoc/DateTime.html

I suggest to add the require 'date' close to the top of that page, to help newcomers not be too
confused about how to use it.

PS: On a side note, perhaps another subsection could be added to the ruby bug/issue tracker here, a subsection
solely for docs? That way, people could report suggestions to improve the documentation there. Anyway that's
just a semi-random suggestion. :)



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>