Issue #12279 has been reported by cremno phobia.

----------------------------------------
Bug #12279: cont.c: wrong _MSC_VER check
https://bugs.ruby-lang.org/issues/12279

* Author: cremno phobia
* Status: Open
* Priority: Normal
* Assignee: 
* ruby -v: 
* Backport: 2.1: DONTNEED, 2.2: DONTNEED, 2.3: REQUIRED
----------------------------------------
2.3.0 and trunk are affected. I wonder why compiling with Visual C++ 6.0 is still supported.

~~~diff
diff --git a/cont.c b/cont.c
index 8ebd78f..729a025 100644
--- a/cont.c
+++ b/cont.c
@@ -657,7 +657,7 @@ fiber_initialize_machine_stack_context(rb_fiber_t *fib, size_t size)
     rb_thread_t *sth = &fib->cont.saved_thread;
 
 #ifdef _WIN32
-# if defined(_MSC_VER) && _MSC_VER <= 0x1200
+# if defined(_MSC_VER) && _MSC_VER <= 1200
 #   define CreateFiberEx(cs, stacksize, flags, entry, param) \
     CreateFiber((stacksize), (entry), (param))
 # endif

~~~




-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>