Issue #12069 has been updated by Yui NARUSE.

Backport changed from 2.1: DONE, 2.2: DONE, 2.3: REQUIRED to 2.1: DONE, 2.2: DONE, 2.3: DONE

ruby_2_3 r54379 merged revision(s) 54097.

----------------------------------------
Bug #12069: [PATCH] document OpenSSL::SSL::SSLContext#setup as MT-unsafe
https://bugs.ruby-lang.org/issues/12069#change-57800

* Author: Eric Wong
* Status: Closed
* Priority: Normal
* Assignee: Zachary Scott
* ruby -v: 
* Backport: 2.1: DONE, 2.2: DONE, 2.3: DONE
----------------------------------------
document OpenSSL::SSL::SSLContext#setup as MT-unsafe

On a cursory inspection, using rb_block_call for extra_chain_cert
is thread-unsafe.  There may be other instances of thread-unsafe
behavior in this method, but one is enough.

* ext/openssl/ossl_ssl.c (ossl_sslctx_setup): document as MT-unsafe


---Files--------------------------------
0001-document-OpenSSL-SSL-SSLContext-setup-as-MT-unsafe.patch (1.12 KB)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>