Issue #12120 has been updated by Nobuyoshi Nakada.

Description updated
Status changed from Open to Feedback

What constraints does `DTRACE_PROBE4` macro have?

----------------------------------------
Bug #12120: [target/sh4] error: 'asm' operand requires impossible reload
https://bugs.ruby-lang.org/issues/12120#change-57196

* Author: John Paul Adrian Glaubitz
* Status: Feedback
* Priority: Normal
* Assignee: 
* ruby -v: 
* Backport: 2.1: UNKNOWN, 2.2: UNKNOWN, 2.3: UNKNOWN
----------------------------------------
Hello!

ruby2.3 fails to build from source on sh4 (Hitachi/Renesas SuperH), the build fails with [1]:

```
gcc -mieee -g -O2 -fstack-protector-strong -Wformat -Werror=format-security -fPIC  -D_FORTIFY_SOURCE=2 -fstack-protector -fno-strict-overflow -fvisibility=hidden -DRUBY_EXPORT -Wdate-time -D_FORTIFY_SOURCE=2   -I. -I.ext/include/sh4-linux-gnu -I./include -I. -o vm.o -c vm.c
In file included from probes.h:10:0,
                 from vm.c:23:
vm_exec.c: In function 'vm_exec_core':
probes.h:21:1: error: 'asm' operand requires impossible reload
 DTRACE_PROBE4 (ruby, method__entry, arg1, arg2, arg3, arg4)
 ^
```

This appears to be a regression in ruby from version 2.2 to 2.3 since ruby2.2 builds fine on the exact same machine [2]. Let me know if you need any more input. The logs can be directly viewed in [1] and [2] and you can set up your own sh4 chroot with the documentation in [3].

Thanks,
Adrian

[1]: https://buildd.debian.org/status/fetch.php?pkg=ruby2.3&arch=sh4&ver=2.3.0-2&stamp=1455247013
[2]: https://buildd.debian.org/status/fetch.php?pkg=ruby2.2&arch=sh4&ver=2.2.4-1&stamp=1454943020
[3]: https://wiki.debian.org/SH4/sbuildQEMU



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>