On 17/02/2016 3:31 AM, <rr.rosas / gmail.com> wrote:
>
> Issue #12075 has been updated by Rodrigo Rosenfeld Rosas.
>
>
> The implementation doesn't have to be the same as the one implemented by
ActiveSupport. I think it would be fine to simply check for nil? and
empty?. But I'd like to keep the names present? and blank? anyway.
>

I'm sure the rails community would love methods with identical names but
different behaviours to suddenly appear in the core.

Personally I don't have a problem with 'nonempty?', since that's the
trinary complement of 'empty' and 'full'.
(supressed text/html)
Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>