Issue #11932 has been updated by Tomoyuki Chikanaga.

Backport changed from 2.0.0: DONTNEED, 2.1: DONTNEED, 2.2: REQUIRED, 2.3: REQUIRED to 2.0.0: DONTNEED, 2.1: DONTNEED, 2.2: DONE, 2.3: REQUIRED

r53411 and r53425 were backported into `ruby_2_2` branch at r53824.

----------------------------------------
Bug #11932: Ripper.sexp can't parse some files from ruby repository and returns nil
https://bugs.ruby-lang.org/issues/11932#change-56987

* Author: Radosaw Buat
* Status: Closed
* Priority: Normal
* Assignee: 
* ruby -v: ruby 2.4.0dev (2015-12-31 trunk 53395) [x86_64-darwin15]
* Backport: 2.0.0: DONTNEED, 2.1: DONTNEED, 2.2: DONE, 2.3: REQUIRED
----------------------------------------
Test file bug.rb:

```ruby
require "ripper"

puts Dir['**/**.rb'].find_all { |f| Ripper.sexp(File.read(f)) == nil }
```

```
$ make runruby TESTRUN_SCRIPT=bug.rb
./miniruby -I./lib -I. -I.ext/common  ./tool/runruby.rb --extout=.ext  -- --disable-gems bug.rb
lib/net/imap.rb
lib/open-uri.rb
lib/rexml/text.rb
test/ruby/test_m17n.rb
test/ruby/test_regexp.rb
```

I didn't find any info in documentation anout returning nil so I assume this is not intended behavior.

---Files--------------------------------
bug.rb (90 Bytes)
reduced_imap.rb (132 Bytes)
reduced_m17n.rb (79 Bytes)
reduced_regexp.rb (42 Bytes)
reduced_open-uri.rb (95 Bytes)
reduced_text.rb (64 Bytes)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>