Issue #12066 has been reported by Kevin Marti.

----------------------------------------
Bug #12066: Ruby creates Wrong .Bat files
https://bugs.ruby-lang.org/issues/12066

* Author: Kevin Marti
* Status: Open
* Priority: Normal
* Assignee: Nobuyoshi Nakada
* ruby -v: ruby 2.2.4p230 (2015-12-16 revision 53155) [x64-mingw32]
* Backport: 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN, 2.3: UNKNOWN
----------------------------------------
After i downloaded the newest version of Ruby and installed SASS, i tried to run SASS from the command line.
This gave me following error:

Der Befehl **"""C:\Program"** ist entweder falsch geschrieben oder
konnte nicht gefunden werden. (In German, but important part is the bold one.)

it says command not found...

So i debugged the sass.bat file and saw that there is a " too much. 
I modified the file from:

@ECHO OFF
IF NOT "%~f0" == "~f0" GOTO :WinNT
@**"**"C:\Program Files\Ruby22-x64\bin\ruby.exe" "C:/Program Files/Ruby22-x64/bin/sass" %1 %2 %3 %4 %5 %6 %7 %8 %9
GOTO :EOF
:WinNT
@**"**"C:\Program Files\Ruby22-x64\bin\ruby.exe" "%~dpn0" %*

to:

@ECHO OFF
IF NOT "%~f0" == "~f0" GOTO :WinNT
@"C:\Program Files\Ruby22-x64\bin\ruby.exe" "C:/Program Files/Ruby22-x64/bin/sass" %1 %2 %3 %4 %5 %6 %7 %8 %9
GOTO :EOF
:WinNT
@"C:\Program Files\Ruby22-x64\bin\ruby.exe" "%~dpn0" %*


Now it works fine. To mention is, that i installed ruby under C:\Program Files and not in the root directly.

So i think the .Bat-Creator is making something strange while writing the file.

I hope you can fix it, so other Peoble dont have to modify every additional bat file.



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>