Issue #12053 has been updated by Bruno Maranhao.


I would love to, but I'm sort of at the mercy of individuals who build the ruby packages for the Arduino. I did try to execute "gem update --system" which I saw as a potential way of circumventing this, but got the following output.

/usr/lib/ruby/2.2/rubygems/core_ext/kernel_require.rb:54:in `require': can't convert false to (null) (false#(null) gives FalseClass) (TypeError)
	from /usr/lib/ruby/2.2/rubygems/core_ext/kernel_require.rb:54:in `require'
	from /usr/lib/ruby/2.2/psych.rb:7:in `<top (required)>'
	from /usr/lib/ruby/2.2/rubygems/core_ext/kernel_require.rb:54:in `require'
	from /usr/lib/ruby/2.2/rubygems/core_ext/kernel_require.rb:54:in `require'
	from /usr/lib/ruby/2.2/rubygems.rb:609:in `load_yaml'
	from /usr/lib/ruby/2.2/rubygems/config_file.rb:328:in `load_file'
	from /usr/lib/ruby/2.2/rubygems/config_file.rb:197:in `initialize'
	from /usr/lib/ruby/2.2/rubygems/gem_runner.rb:74:in `new'
	from /usr/lib/ruby/2.2/rubygems/gem_runner.rb:74:in `do_configuration'
	from /usr/lib/ruby/2.2/rubygems/gem_runner.rb:39:in `run'
	from /usr/bin/gem:21:in `<main>'

----------------------------------------
Bug #12053: Issue with installing pubnub gem on Arduino Yun
https://bugs.ruby-lang.org/issues/12053#change-56898

* Author: Bruno Maranhao
* Status: Feedback
* Priority: Normal
* Assignee: 
* ruby -v: 
* Backport: 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN, 2.3: UNKNOWN
----------------------------------------
Hi, I've installed all of the Ruby packages available here (http://download.rsdev.16mb.com/OpenWrt/ChaosCalmer_15.05/ArduinoYun/packages/packages/), including ruby-gems. Now I'm trying to install the Pubnub Ruby SDK with the command "gem install pubnub" and I am getting the output below. I'm new to Ruby and can't make heads from tails. Any help is appreciated. I've also downloaded the code from GitHub, so if someone can explain to me how to install it from that folder rather than this automated fashion that would work as well.

Thanks!



---Files--------------------------------
bug-12053.log (9.84 KB)


-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>