Issue #9817 has been updated by Nobuyoshi Nakada.

Status changed from Open to Feedback

First of all, from where did your "openssl" libraries come?
`ws2_32.lib` should be linked by the default, and I can't get why openssl needs GDI.

----------------------------------------
Bug #9817: The extconf.rb for OpenSSL assumes MingW
https://bugs.ruby-lang.org/issues/9817#change-56832

* Author: Daniel Berger
* Status: Feedback
* Priority: Normal
* Assignee: openssl
* ruby -v: ruby 2.1.1p76 (2014-02-24 revision 45161) [i386-mswin32_100]
* Backport: 2.0.0: UNKNOWN, 2.1: UNKNOWN
----------------------------------------
It appears that the extconf.rb file for openssl assumes mingw. The problem is that gdi32 and wsock32 need to be linked, even for Visual Studio.

The simple fix is to change "`if $mingw`" to "`if File::ALT_SEPARATOR`" on line 40.




-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>