Issue #12042 has been updated by Nobuyoshi Nakada.

Status changed from Open to Feedback

I'm uncertain about what you mean by "change".
Could you elaborate the behavior what you expect?

----------------------------------------
Feature #12042: A better interface that returns a list of local variables available where the exception is raised
https://bugs.ruby-lang.org/issues/12042#change-56825

* Author: Yuki Nishijima
* Status: Feedback
* Priority: Normal
* Assignee: 
----------------------------------------
We've changed the behavior of `NameError#local_variables` as discussed on #11777, but I'm not actually satisfied by the change. This change has made it impossible to get a list of local variables available within a NameError scope. It would be nice, if we could add a new method that does what `NameError#local_variables` does right now, and change the `local_variables` method back to the previous behavior.

I actually don't have a good name in mind, but please let me know if anyone has a good name for it.



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>