Issue #11118 has been updated by Yui NARUSE.

Backport changed from 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN to 2.0.0: WONTFIX, 2.1: WONTFIX, 2.2: WONTFIX, 2.3: WONTFIX

I also write about this on Microsoft Connect.
https://connect.microsoft.com/VisualStudio/feedback/details/1279133

You may understand the situation by seeing  https://github.com/ruby/ruby/pull/884.

Status is
* Ruby 2.3 or prior won't fix this.
* Ruby 2.4 or later may introduce with fundamental architectural change.

----------------------------------------
Bug #11118: Unable to build Ruby with Visual Studio 2015 RC
https://bugs.ruby-lang.org/issues/11118#change-56509

* Author: Daniel Berger
* Status: Open
* Priority: Normal
* Assignee: 
* ruby -v: 2.2.2
* Backport: 2.0.0: WONTFIX, 2.1: WONTFIX, 2.2: WONTFIX, 2.3: WONTFIX
----------------------------------------
I installed the latest Visual Studio, and then tried to build Ruby 2.2.2 on Windows 7. But, I'm having trouble right away. This is an RC candidate (so I guess that's why the CLI shows Visual Studio 14).

C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC>cl /?
Microsoft (R) C/C++ Optimizing Compiler Version 19.00.22816 for x86
Copyright (C) Microsoft Corporation.  All rights reserved.

C:\Users\djberge\Downloads\Ruby\ruby-2.2.2>win32\configure.bat
win32\rtname: conftest.exe is not linked to msvcrt
NMAKE : fatal error U1077: 'win32\rtname' : return code '0x1'
Stop.

Any ideas?



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request / ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>