Issue #11832 has been reported by Martin Drst.

----------------------------------------
Bug #11832: Error installing(?) libffi on a new source checkout
https://bugs.ruby-lang.org/issues/11832

* Author: Martin Drst
* Status: Open
* Priority: Normal
* Assignee: Nobuyoshi Nakada
* ruby -v: ruby 2.3.0dev (2015-12-16 trunk 53139) [x86_64-cygwin]
* Backport: 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN
----------------------------------------
I get the error below on a new checkout of trunk. It doesn't happen on an older checkout.

downloading did_you_mean-1.0.0.rc1.gem ... done
downloading for ext/fiddle/extlibs
downloading libffi-3.2.1.tar.gz ... done
checking md5 of .downloaded-cache/libffi-3.2.1.tar.gz ... OK
extracting .downloaded-cache/libffi-3.2.1.tar.gz into ext/fiddle
applying win32/libffi-3.2.1-mswin.patch under ext/fiddle
tool/extlibs.rb:73:in `spawn': No such file or directory - patch (Errno::ENOENT)
        from tool/extlibs.rb:73:in `do_patch'
        from tool/extlibs.rb:108:in `block (3 levels) in <main>'
        from tool/extlibs.rb:103:in `foreach'
        from tool/extlibs.rb:103:in `block (2 levels) in <main>'
        from tool/extlibs.rb:96:in `glob'
        from tool/extlibs.rb:96:in `block in <main>'
        from tool/extlibs.rb:95:in `each'
        from tool/extlibs.rb:95:in `<main>'
uncommon.mk:1032: recipe for target 'extract-extlibs' failed
make[1]: *** [extract-extlibs] Error 1
make[1]: Leaving directory '/cygdrive/c/Data/ruby-ci'
uncommon.mk:960: recipe for target 'up' failed
make: [up] Error 2 (ignored)
compiling version.c
generating x86_64-cygwin-fake.rb
/bin/sh: line 1: ./miniruby.exe: No such file or directory
uncommon.mk:568: recipe for target 'x86_64-cygwin-fake.rb' failed
make: *** [x86_64-cygwin-fake.rb] Error 127





-- 
https://bugs.ruby-lang.org/