nobu / ruby-lang.org wrote:
> Now `BasicSocket` has `do_not_reverse_lookup` global and per-socket attributes.
> Negative flag makes less readability.
> So I propose the inverse and positive attributes,
> 
> * `BasicSocket.reverse_lookup`
> * `BasicSocket.reverse_lookup=`

I prefer we skip these globals and deprecate the existing global ones.
(and maybe even deprecating per-socket).

It's a complete performance killer to enable reverse lookup and nobody
should be doing it for every socket.