Issue #11682 has been updated by Nobuyoshi Nakada.

Status changed from Open to Rejected

You load an extension library for older version of ruby.
2.2.1 is outdated and 2.2.3 will show more descriptive message.

~~~
$ ruby2.2 -v -r /usr/lib/ruby/2.0.0/universal-darwin15/etc.bundle -ep
ruby 2.2.3p173 (2015-08-18 revision 51636) [universal.x86_64-darwin15]
/opt/local/lib/ruby2.2/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require': incompatible library version - /usr/lib/ruby/2.0.0/universal-darwin15/etc.bundle (fatal)
	from /opt/local/lib/ruby2.2/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require'
~~~


----------------------------------------
Bug #11682: cant create my first controller after initial rails install
https://bugs.ruby-lang.org/issues/11682#change-54839

* Author: Jasel Chauhan
* Status: Rejected
* Priority: Normal
* Assignee: 
* ruby -v: 2.2.1
* Backport: 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN
----------------------------------------
hi there, i'm having difficulty in creating my first rails controller - i have just installed rails following the installrails.com instructions.
when typing 'rails generate controller welcome index" into my terminal I am presented with the attached error bug log.

Any ideas as to what could be causing this??

Help is muchos appreciated :)

J

---Files--------------------------------
bugCrashLog.txt (78.3 KB)


-- 
https://bugs.ruby-lang.org/