Issue #11666 has been updated by Yukihiro Matsumoto.


Accepted. But we have naming issue.  `private?` or `private_addr?` or something else?
Any comments?

Matz.


----------------------------------------
Feature #11666: IPAddr#private?
https://bugs.ruby-lang.org/issues/11666#change-54777

* Author: Masaki Matsushita
* Status: Open
* Priority: Normal
* Assignee: Masaki Matsushita
----------------------------------------
I propose a new feature: IPAddr#private?.

Example:

```ruby
IPAddr.new("192.168.1.1").private? #=> true.
```

---Files--------------------------------
patch.diff (1.58 KB)


-- 
https://bugs.ruby-lang.org/