It's still asking for a JS runtime:

  /lib/ruby/gems/2.3.0/gems/execjs-2.4.0/lib/execjs/runtimes.rb:45:in `autodetect': Could not find a JavaScript runtime. See https://github.com/sstephenson/execjs for a list of available runtimes

Sorry I can't trust JS to run.
Do you have standalone Ruby code to reproduce the issue?
Also, does this error happen on GNU/Linux systems with NPTL?
Maybe it is a platform-dependent threading bug.