Issue #11548 has been updated by Willian Veiga.

File bug11548.patch added

I have created a patch. This is my first contribution here. Sorry if I am doing something wrong.
Thank you very much.

----------------------------------------
Misc #11548: FileUtils#remove_tailing_slash is a poor method name
https://bugs.ruby-lang.org/issues/11548#change-54331

* Author: Ryan Hosford
* Status: Open
* Priority: Normal
* Assignee: 
----------------------------------------
One would expect this method to be called `remove_trailing_slash`

I asked around on IRC and the consensus is this is probably an unfortunate typo that's survived too long.

Tailing and Trailing mean similar things, but I think most would expect "trailing" to be the clear choice here.

http://ruby-doc.org/stdlib-2.2.3/libdoc/fileutils/rdoc/FileUtils.html#method-i-remove_tailing_slash

---Files--------------------------------
bug11548.patch (1.83 KB)


-- 
https://bugs.ruby-lang.org/