Issue #11542 has been updated by Lingaraj Kothokatta.

ruby -v set to ruby 2.2.0p0 (2014-12-25 revision 49005) [i386-linux]

----------------------------------------
Bug #11542: Zlib::DataError: incorrect data check
https://bugs.ruby-lang.org/issues/11542#change-54248

* Author: Lingaraj Kothokatta
* Status: Open
* Priority: Normal
* Assignee: 
* ruby -v: ruby 2.2.0p0 (2014-12-25 revision 49005) [i386-linux]
* Backport: 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN
----------------------------------------
When I trying to send HTTP POST, I am getting follolwing Error


Zlib::DataError: incorrect data check
/usr/local/rvm/rubies/ruby-2.2.0/lib/ruby/2.2.0/net/http/response.rb:377:in `inflate'
/usr/local/rvm/rubies/ruby-2.2.0/lib/ruby/2.2.0/net/http/response.rb:377:in `block in inflate_adapter'
/usr/local/rvm/rubies/ruby-2.2.0/lib/ruby/2.2.0/net/protocol.rb:411:in `call_block'
/usr/local/rvm/rubies/ruby-2.2.0/lib/ruby/2.2.0/net/protocol.rb:402:in `<<'
/usr/local/rvm/rubies/ruby-2.2.0/lib/ruby/2.2.0/net/protocol.rb:106:in `read'
/usr/local/rvm/rubies/ruby-2.2.0/lib/ruby/2.2.0/net/http/response.rb:399:in `read'
/usr/local/rvm/rubies/ruby-2.2.0/lib/ruby/2.2.0/net/http/response.rb:289:in `block in read_body_0'
/usr/local/rvm/rubies/ruby-2.2.0/lib/ruby/2.2.0/net/http/response.rb:260:in `inflater'
/usr/local/rvm/rubies/ruby-2.2.0/lib/ruby/2.2.0/net/http/response.rb:279:in `read_body_0'
/usr/local/rvm/rubies/ruby-2.2.0/lib/ruby/2.2.0/net/http/response.rb:201:in `read_body'
/usr/local/rvm/rubies/ruby-2.2.0/lib/ruby/2.2.0/net/http.rb:1398:in `block in send_entity'
/usr/local/rvm/rubies/ruby-2.2.0/lib/ruby/2.2.0/net/http.rb:1420:in `block (2 levels) in transport_request'
/usr/local/rvm/rubies/ruby-2.2.0/lib/ruby/2.2.0/net/http/response.rb:162:in `reading_body'
/usr/local/rvm/rubies/ruby-2.2.0/lib/ruby/2.2.0/net/http.rb:1419:in `block in transport_request'
/usr/local/rvm/rubies/ruby-2.2.0/lib/ruby/2.2.0/net/http.rb:1410:in `catch'
/usr/local/rvm/rubies/ruby-2.2.0/lib/ruby/2.2.0/net/http.rb:1410:in `transport_request'
/usr/local/rvm/rubies/ruby-2.2.0/lib/ruby/2.2.0/net/http.rb:1383:in `request'
/usr/local/rvm/rubies/ruby-2.2.0/lib/ruby/2.2.0/net/http.rb:1376:in `block in request'
/usr/local/rvm/rubies/ruby-2.2.0/lib/ruby/2.2.0/net/http.rb:853:in `start'
/usr/local/rvm/rubies/ruby-2.2.0/lib/ruby/2.2.0/net/http.rb:1374:in `request'
/usr/local/rvm/rubies/ruby-2.2.0/lib/ruby/2.2.0/net/http.rb:1397:in `send_entity'
/usr/local/rvm/rubies/ruby-2.2.0/lib/ruby/2.2.0/net/http.rb:1186:in `post'



-- 
https://bugs.ruby-lang.org/