Matz, others:

Is there any chance we could get a RUBYOPT variable that's specific  
to the Ruby version?  IE:

RUBYOPT18="-rubygems"
RUBYOPT19=""

Ruby 1.8 only listens to RUBYOPT18 (and RUBYOPT like normal).  Ruby  
1.9 only listens to RUBYOPT19 (and RUBYOPT).  This way, if you run  
both versions on the system you can customize which RUBYOPTs go to  
which version you are using.

Thanks,
Caleb